‫אלון גולדמן‬‎

hey,
im trying to add a new container, and make it apeare as an option page.
i save it, and everything is cool.

but when i try to reach the option page, i get this message: "you are not allowed to access this page".
if i try to add the container into a post, it works. it doenst work only when i try to add this as a option page.
i tried setting permission to everyone in the container setting; butit didnt work.

how can i solve this?
thanks!

August 8, 2018 at 12:00
Noahj Champion

Hi!

Did you try setting the https://www.ultimate-fields.com/docs/quick-start/container-settings/#roles-capabilities $container->require_role(NULL); $container->require_capability(NULL)?

If that doesn't work, then I would double check that your options pages, it surely the exact same as your container location. It could be they are not and so the optins page itself doesn't actually exist. This mistake (which I have made several times in just typing to fast) will return this message.

If that doesn't work, then it should be the role or capabilities within you as the admin user. The default Wordpress admin user should have the proper capabilities by default.

Just chipping in, as I had run into this while developing with UF too.

August 8, 2018 at 15:57
Noahj Champion

So now all my container setups look like this pretty much. I keep enabled what I can for quick changing, but set NULL or EMPTY, etc. if needed.

image

August 8, 2018 at 15:58

If you have problems setting up Ultimate Fields or the fields are not working as you expected, you can discuss your issue here.

If the issue is specific to a Pro feature, please post in the “Ultimate Fields Pro” forum.

Docs

Have you checked the documentation?

Ultimate Fields is fully documented. Please check the documentation or use the search before posting a new topic.

Read the docs

Demo

Once you are registered, you can request a demo instance, where you can try Ultimate Fields before usage or purchase.

No strings attached.

Request a demo